Outage detected
Incident Report for KnowledgeOwl
Postmortem

One of our servers went into a failing state and began issuing a vast amount of internal connection requests. Those requests overloaded our network.

Rebooting the server solved the issue, and internal traffic patterns have returned to normal.

Next steps

We are reviewing our alarms on the affected server to see if we could have detected the failure sooner and prevented the downtime.

Posted Nov 06, 2023 - 14:15 EST

Resolved
Our fix seems to have fully resolved the issue; we'll be issuing a postmortem shortly to explain root cause in more detail. Thank you all for your patience today!
Posted Nov 06, 2023 - 14:08 EST
Monitoring
We seem to be back to normal operations, but we're continuing to monitor performance and finish our investigation of the initial root cause.
Posted Nov 06, 2023 - 13:41 EST
Update
We are continuing to investigate this issue.
Posted Nov 06, 2023 - 13:36 EST
Investigating
We just started seeing reports and warnings that KnowledgeOwl is down. Our team is focusing on getting it sorted and back online ASAP.
Posted Nov 06, 2023 - 13:31 EST
This incident affected: Knowledge Bases, Web Application, and API.