Unsafe files warning from Microsoft Defender SmartScreen

Incident Report for KnowledgeOwl

Postmortem

Microsoft Edge users experienced security warnings when accessing knowledge base files due to a SmartScreen flag on our file hosting domain. No data was compromised. We have deployed additional safeguards to prevent recurrence.

Posted Apr 01, 2026 - 19:07 EDT

Resolved

This incident has been resolved. Microsoft has reviewed and unflagged our file library. Files uploaded to KnowledgeOwl should no longer be marked as unsafe in Microsoft Edge.

If you are still experiencing issues, please contact support.
Posted Apr 01, 2026 - 18:39 EDT

Identified

This issue is limited to Microsoft Edge. Someone flagged a file uploaded to a KnowledgeOwl trial account as phishing, which has since been resolved with AWS (the file and trial account were deleted). However, Microsoft Edge is now flagging all files uploaded to KnowledgeOwl as unsafe. We've submitted a report to Microsoft requesting a review. In the meantime, Edge users can help by reporting the site as safe.
Posted Apr 01, 2026 - 17:21 EDT

Investigating

We are investigating reports of files being marked as unsafe by Microsoft Defender SmartScreen. We are working on a fix.
Posted Apr 01, 2026 - 16:40 EDT
This incident affected: File and Resource CDN.