System outage
Incident Report for KnowledgeOwl
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 29, 2019 - 12:59 MDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jun 29, 2019 - 12:43 MDT
This incident affected: Knowledge Bases, Web Application, and API.