Site outage
Incident Report for KnowledgeOwl
Postmortem

Summary:

We faced an unsuccessful Denial of Service (DoS) attempt that caused degraded performance for many customers.

Next steps:

As part of our infrastructure upgrades, we’re testing and reviewing anti-DoS measures. Once implemented, these measures will prevent future DoS attempts like this.

Posted May 20, 2021 - 18:37 EDT

Resolved
We've resolved the issue. Thanks for bearing with us and we are so sorry for the trouble today. We appreciate everyone who reported the problem and helped to confirm the fix. If you are still having issues, please email us at support@knowledgeowl.com.
Posted May 20, 2021 - 16:53 EDT
Update
Performance seems to be back to normal for all customers who've reported and responded to our follow-ups. We are continuing to monitor the solution.
Posted May 20, 2021 - 16:18 EDT
Monitoring
We've identified the issue and released a fix, which already seems to be working for most customers. We're continuing to monitor results.
Posted May 20, 2021 - 15:49 EDT
Investigating
We've had reports of 500 application errors and/or generalized slowness in the KnowledgeOwl application, knowledge bases, and API. Right now we're treating this as a major outage and are investigating; we'll provide updates as soon as we have more information.
Posted May 20, 2021 - 15:20 EDT
This incident affected: Knowledge Bases, Web Application, and API.