Outage
Incident Report for KnowledgeOwl
Postmortem

Incident postmortem

One of our internal server monitoring systems went down and failed to alert us to an issue this morning. Because we did not receive the alert, it took us longer than normal to diagnose and fix the problem.

We've since found and fixed the issue to restore service.

Next steps

To prevent this in the future, we are looking to improve our monitoring and notifications.

Posted Mar 24, 2021 - 12:53 EDT

Resolved
Sorry for interruption today, and thank you to all the customers who reported issues and for your patience while we got things sorted.

One of our internal server monitoring systems went down and failed to alert us to an issue this morning. Because we did not receive the alert, it took us longer than normal to diagnose and fix the problem. We've since found and fixed the issue to restore service. To prevent this in the future, we are looking to improve our monitoring and notifications.
Posted Mar 24, 2021 - 12:30 EDT
Update
We've rolled out an additional set of fixes that seem to have resolved issues for customers who were reporting issues. We'll continue to monitor for further alerts or issues.
Posted Mar 24, 2021 - 11:13 EDT
Monitoring
We've implemented a fix. Most traffic to knowledge bases, the KnowledgeOwl web application, and API should be unaffected, but we are continuing to monitor and tweak things.
Posted Mar 24, 2021 - 10:14 EDT
Investigating
We are currently investigating an issue with KnowledgeOwl. This affects both the knowledge base software, and published knowledge bases.
Posted Mar 24, 2021 - 07:26 EDT
This incident affected: Knowledge Bases, Web Application, and API.