Reports of slowness and intermittent 504 errors
Incident Report for KnowledgeOwl
Postmortem

We identified two processes that contributed to this week's slowness during our investigation. Both have been on our list to update, but we're prioritizing them as a result of this week's incident.

We're already testing a fix for the first process. The second is a larger change that will take longer to resolve.

We'll include these fixes in our normal release notes, identified as "performance improvements".

Thank you all for your patience this--and every--week.

Posted Mar 16, 2023 - 10:30 EDT

Resolved
This incident has been resolved.
Posted Mar 14, 2023 - 13:03 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 14, 2023 - 12:57 EDT
Update
This appears to be resolved. Thanks to everyone who reported the problem and sorry for the trouble today!
Posted Mar 14, 2023 - 12:57 EDT
Monitoring
The issues seem to have subsided around 11:45 ET. We are currently keeping an eye on it and will wait a bit before marking the issue as resolved.
Posted Mar 14, 2023 - 12:06 EDT
Investigating
We have received multiple reports of slowness and intermittent 504 errors. We are currently investigating and will report back asap. Sorry for the trouble and thanks to everyone for letting us know!
Posted Mar 14, 2023 - 11:44 EDT
This incident affected: Knowledge Bases and Web Application.