Reports of knowledge base and app slowness

Incident Report for KnowledgeOwl

Postmortem

Thank you for your patience through yesterday’s incident. We know performance impacts to our app and your live knowledge bases are never pleasant, and we appreciate your patience and grace while we worked through things.

Here’s a brief postmortem of what happened and our steps to remediate:

An unexpected spike in traffic led to intermittent 504 errors.

To maintain core system availability, we temporarily restricted computationally heavy operations while scaling our infrastructure.

Once that was complete, we returned back to normal operations. We’ve noticed no significant spikes or errors since then.

Posted Apr 23, 2026 - 15:48 EDT

Resolved

Our fix seems to be working and we haven't seen any further issues. We'll share a post-mortem tomorrow. Thank you for your patience today!
Posted Apr 22, 2026 - 14:41 EDT

Monitoring

We've rolled out a fix for the issue and we're monitoring performance.
Posted Apr 22, 2026 - 12:10 EDT

Identified

We've identified the issue and are working to implement a fix.
Posted Apr 22, 2026 - 11:22 EDT

Investigating

We're investigating reports of 504 gateway timeouts and other slowness accessing knowledge bases and the KnowledgeOwl application.
Posted Apr 22, 2026 - 11:15 EDT
This incident affected: Knowledge Bases, Web Application, and API.